TIP

本文档为安装引导附录,若您已经完成了系统的安装,无需阅读此文档,请移步进阶 (opens new window)

# 准备PHP

BuildAdmin要求PHP版本 >= 7.2.5 安装程序会对此进行检测,若不满足条件,请按以下指南操作

# Windows系统

  1. 要求系统已安装PHP,且版本>=7.2.5
  2. 要求对应PHP已添加到系统环境变量
  3. 如果是PHP版本不足,也请参考下面的引导,安装一个版本足够的PHP

# 安装PHP

  • 您可以使用任何可能的方式安装PHP,比如宝塔面板、phpStudy、官方下载安装等
  1. 此处以phpStudy为例
  2. 前往 phpStudy官网 (opens new window) 下载安装包
  3. 如Windows下的常规软件安装一样,凭感觉下一步直到安装完成
  4. 运行phpStudy,在软件首页,启动Mysql服务

# 添加PHP到环境变量

  1. 打开cmdWindows PowerShell
  2. 执行命令php -v,如果有提示出来>=7.2.5的PHP版本,则您无需继续下面的操作,您的PHP已经准备好了
  3. php -v提示找不到命令,先找到PHP的安装目录,比如我的phpStudy安装在G:\program files\phpstudy_pro则PHP目录为G:\program files\phpstudy_pro\Extensions\php\php7.2.9nts,该目录内包含php.exe文件
  4. 按下Win+R,输入sysdm.cpl,在打开的窗口中切换到高级,点击环境变量
  5. 点击系统变量列表中的Path,点击编辑按钮
  6. 点击新建,输入PHP所在目录,确定保存后,执行第1-2步,若无效请打开新的命令提示符窗口或重启电脑使环境变量生效

# Linux或Mac系统

  • 您可以使用任何可能的方式安装PHP,比如宝塔面板、phpStudy、官方下载编译安装等
  1. 请自行查找怎么将PHP添加到环境变量,相信对于Linux用户来说,这不是难事,多数情况在您安装时,就已经自动添加进去了,那么就不再需要此步骤
  2. 打开终端
  3. 执行命令php -v,如果有提示出来>=7.2.5的PHP版本,则您的PHP已经准备好了
  4. PHP需要安装好fileinfocalendar扩展,这两个扩展在Linux下通常是没有默认安装的,

# 参考链接